home  wiki

ConfigsZebraOspfd

Backbone router

These configurations are illustrative only. IP addresses will obviously need to be changed. Configurations from Zebra 0.92a. Have not yet been tested. tunl0 will need creation from shell using ip tunnel etc. Configurations for internal routers, and ASBR not yet available. ASBR will be basically the same as below, with some additional redistribute commands, potentially also with bpgd.conf.

If you have the following message appear:
[[root@fartlek etc]# zebra -d
2002/05/15 22:45:24 ZEBRA: can't create router advertisement socket: Address
family not supported by protocol
There is no such command.
Error occured during reading below line.
 ipv6 nd suppress-ra


then you don't have IPv6 support. Try modprobe ipv6.


zebra.conf

!
! Zebra configuration saved from vty
!   2002/04/15 23:38:48
!
hostname zooropa
password secret
enable password secret
log file zebra.log
!
interface lo
 ipv6 nd suppress-ra
!
interface sit0
 ipv6 nd suppress-ra
!
! eth0 is wireless LAN link one
!interface eth0
 ip address 172.16.80.1/23
 no ipv6 nd suppress-ra
!
! eth1 is wireless LAN link two for local hosts
interface eth1
 ip address 10.10.1.1/28
 no ipv6 nd suppress-ra
!
interface ppp0
 ipv6 nd suppress-ra
!
! a tunnel interface to emulate a hoped for wireless connection over Internet
interface tunl0
 ipv6 nd suppress-ra
 ip address 172.16.80.2/23
line vty



ospfd.conf

!
! Zebra configuration saved from vty
!   2002/04/17 01:05:48
!
hostname zooropa
password secret
enable password secret
log stdout
!
!
!
interface lo
!
! the WAN wireless, IBSS mode, must use point-to-multipoint
interface eth0
 ip ospf network point-to-multipoint
!
! the local host wireless - no config needed, doesn't run OSPF
interface eth1
!
interface sit0
!
! our Internet tunnel
interface tunl0
 ip ospf network point-to-point
!
router ospf
 ! the router-id is the lowest of the assigned 172.16 space addresses
 ! maybe generate automatically?
 ospf router-id 172.16.80.1
 ! redistribute connected routes, eg. to the 10.10.1.1/28 that is configured
 ! in zebra
 redistribute connected
 ! this is the network that all backbone routers must agree as being area 0
 network 172.16.80.0/23 area 0
!
line vty
!


Version 1 (current) modified Tue, 03 Jul 2007 23:11:56 +1000 by graybeard
[EditText] [Spelling] [Current] [Raw] [Code] [Diff] [Subscribe] [VersionHistory] [Revert] [Delete] [RecentChanges]
> home> about> events> files> members> maps> wiki board   > home   > categories   > search   > changes   > formatting   > extras> site map

Username
Password

 Remember me.
>

> forgotten password?
> register?
currently 0 users online
Node Statistics
building122
gathering192
interested464
operational249
testing201